ASI erratic.

Any DA20 related topics

Moderators: Rick, Lance Murray

User avatar
DiamondFlyer88
2 Diamonds Member
2 Diamonds Member
FIRST NAME: Alex
Aircraft: DA20-C1
Registration: N373AM
Airport: KSEE

Posts: 15
Joined: Sat Dec 02, 2017 1:03 am

ASI erratic.

Postby DiamondFlyer88 » Thu Feb 08, 2018 11:08 pm

Hi guys!

One of my girls is having an issue with the ASI reading zero most of the time during flight, at times it pegs to the top and dances around 40 kts for a bit and goes back to ZERO. I have had the air blown through the pitot line and the ASI bench tested and found to be working fine.. The static system is working fine as well. It is only the airspeed indicator with the issue.

Any thoughts on what could be the problem? Has anyone experienced anything similar?
User avatar
1911Tex
3 Diamonds Member
3 Diamonds Member
FIRST NAME: Larry
Aircraft: DA20-C1
Registration: N389DC
Airport: KGTU

Posts: 86
Joined: Sun May 14, 2017 1:38 am
Has thanked: 2 times
Been thanked: 5 times

Re: ASI erratic.

Postby 1911Tex » Fri Feb 09, 2018 2:53 pm

Was the air blown through the pitot line in reverse (from the tube behind the ASI out)? May be debris (bug?). Need to be extremely careful not to produce more than very light breath pressure from pitot to ASI.
User avatar
DiamondFlyer88
2 Diamonds Member
2 Diamonds Member
FIRST NAME: Alex
Aircraft: DA20-C1
Registration: N373AM
Airport: KSEE

Posts: 15
Joined: Sat Dec 02, 2017 1:03 am

Re: ASI erratic.

Postby DiamondFlyer88 » Mon Feb 12, 2018 7:01 pm

Yeah it was blown from the ASI out. I will have the shop check if the pitot tube itself is not the one with the problem..
User avatar
Derek
2 Diamonds Member
2 Diamonds Member
FIRST NAME: Derek
Aircraft: DA20
Registration: GIVD
Airport: CNU8

Posts: 38
Joined: Fri Apr 06, 2012 7:07 am
Has thanked: 4 times
Been thanked: 7 times

Re: ASI erratic.

Postby Derek » Tue Feb 13, 2018 1:51 am

Is the pitot tube covered when not in use? If not it could have debris from bugs in it, perhaps mud wasps. Try taking the Pitot off and cleaning it out.
User avatar
1911Tex
3 Diamonds Member
3 Diamonds Member
FIRST NAME: Larry
Aircraft: DA20-C1
Registration: N389DC
Airport: KGTU

Posts: 86
Joined: Sun May 14, 2017 1:38 am
Has thanked: 2 times
Been thanked: 5 times

Re: ASI erratic.

Postby 1911Tex » Wed Feb 14, 2018 2:14 pm

Also and no less important...I had a 182 with the same problem; turned out that the plastic tube at the inlet of the ASI had a hard to see crack or split where it connected. Might check that out as well?
User avatar
DiamondFlyer88
2 Diamonds Member
2 Diamonds Member
FIRST NAME: Alex
Aircraft: DA20-C1
Registration: N373AM
Airport: KSEE

Posts: 15
Joined: Sat Dec 02, 2017 1:03 am

Re: ASI erratic.

Postby DiamondFlyer88 » Fri Mar 09, 2018 4:42 am

The problem was the tubes were zip-tied too tightly together under the seats. Cut the zip-tie off and put a new one. ASI working just fine now. Thanks guys!

Who is online

Users browsing this forum: No registered users and 1 guest