Garmin 1000 Nav Data update problem

Any DA40 related topics

Moderators: Rick, Lance Murray

Post Reply
Cumulusab
1 Diamond Member
1 Diamond Member
FIRST NAME: Alan
Aircraft: DA40
Registration: N668DS
Airport: LELH

Posts: 1
Joined: Wed Jan 02, 2019 7:29 pm

Garmin 1000 Nav Data update problem

Post by Cumulusab » Tue Mar 12, 2019 10:23 am

Hi ,
We happily used Jepessen to update the garmin 1000 till March 2016.

For various reasons we did not try to update again till November 2018 - without success. Several further attempts have also failed.

We install the micro disc power off as usual/as we always did, then power up, but do not get the update option. It does not 'see' the data.

We use a 4mb Sansdisc as before. The Garmin is Diamond DA40 System 0321.22

Any tips to solve appreciated. (we are based in Murcia Spain).

Kind Regards
Alan
User avatar
Ultrapilot1
3 Diamonds Member
3 Diamonds Member
FIRST NAME: Steven
Aircraft: DA40
Registration: N446SB
Airport: KPIE

Posts: 86
Joined: Wed Nov 12, 2014 9:19 pm
Has thanked: 17 times
Been thanked: 8 times

Re: Garmin 1000 Nav Data update problem

Post by Ultrapilot1 » Tue Mar 12, 2019 6:32 pm

I just tried to update mine and ran into the same problem. Error code says the sd card is invalid. Never had a problem before.
User avatar
OriensFlight
2 Diamonds Member
2 Diamonds Member
FIRST NAME: Hans
Aircraft: DA40
Registration: N556LU
Airport: KSTS

Posts: 24
Joined: Thu Mar 15, 2018 2:59 pm
Has thanked: 9 times
Been thanked: 4 times

Re: Garmin 1000 Nav Data update problem

Post by OriensFlight » Tue Mar 12, 2019 7:53 pm

Garmin's support was pretty good when I called them last time. You may want to try that first.

I was able to install the February update with the regular process without issue in N556LU (DA40.763).
Hans
N556LU / 40.763 - 2007 DA40 XL w/WAAS & ADS-B @ RAM Aviation in Santa Rosa, California
User avatar
pietromarx
4 Diamonds Member
4 Diamonds Member
FIRST NAME: Peter
Aircraft: DA40
Registration: NZZZ
Airport: KWHP

Posts: 235
Joined: Fri Oct 07, 2016 2:52 am
Has thanked: 7 times
Been thanked: 53 times

Re: Garmin 1000 Nav Data update problem

Post by pietromarx » Tue Mar 12, 2019 11:56 pm

I've seen this occasionally with SD cards in the G1000. The solution has always been to just create a new complete set of databases (using the Garmin application on either Windoze or Mac) on a new SD card. For whatever reason, the SD cards aren't always reliable and computers, including the G1000 occasionally have issues recognizing, reading, and writing to them. (And despite their name, they're not secure).

Garmin makes it very easy to recreate an entirely new set of cards and I use identical ones in both the PFD and MFD even though the databases are different as the system can cross-create databases in case of loss.
User avatar
Ultrapilot1
3 Diamonds Member
3 Diamonds Member
FIRST NAME: Steven
Aircraft: DA40
Registration: N446SB
Airport: KPIE

Posts: 86
Joined: Wed Nov 12, 2014 9:19 pm
Has thanked: 17 times
Been thanked: 8 times

Re: Garmin 1000 Nav Data update problem

Post by Ultrapilot1 » Wed Mar 13, 2019 4:52 pm

I did purchase a new set of SD cards and formatted them and result is still the same. I contacted Garmin we deleted the Flygarmin app and re-installed it, but result is still the same. I get a default message "MFD1 card 2 invalid". If i Move that card to the pfd then I get the same message but starts with pfd1 card etc. Today I made another new set and will try again. If result is the same then I'll go back to Garmin support and see if they have another idea. The Nav data updates fine so the problem is only the lower cards.
Post Reply